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File Manager Functionality
The Caja file manager provides a simple and integrated way to manage your

files and applications. You can use the file manager to do the following:

Create folders and documents

Display your files and folders

Search and manage your files

Run scripts and launch applications

Customize the appearance of files and folders

Open special locations on your computer

Write data to a CD or DVD

Install and remove fonts

The file manager lets you organize your files into folders. Folders can contain files and may also contain other

folders. Using folders can help you find your files more easily.

Caja also manages the desktop. The desktop lies behind all other visible items on your screen. The desktop is

an active component of the way you use your computer.

Every user has a Home Folder. The Home Folder contains all of the user's files. The desktop is another folder.

The desktop contains special icons allowing easy access to the users Home Folder, Trash, and also removable

media such as floppy disks, CDs and USB flashdrives.

Caja is always running while you are using MATE. To open a new Caja window, double-click on an appropriate

icon on the desktop such as Home or Computer, or choose an item from Places menu on the top panel.

In MATE many things are files, such as word processor documents, spreadsheets, photos, movies, and music.
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File Manager Presentation
Caja provides two modes in which you can interact with your filesystem:

spatial and browser mode. You may decide which method you prefer and set Caja to always use this by

selecting (or deselecting) Always open in browser windows in the Behavior tab of the Caja Preferences.

Spatial mode is the default in MATE, but your distributor, vendor, or system administrator may have configured

Caja to use browser mode by default.

The following explains the difference between the two modes:

Browser mode: browse your files and folders

The file manager window represents a browser, which can display any location. Opening a folder updates

the current file manager window to show the contents of the new folder.

As well as the folder contents, the browser window displays a toolbar with common actions and locations, a

location bar that shows the current location in the hierarchy of folders, and a sidebar that can hold

different kinds of information.

In Browser Mode, you typically have fewer file manager windows open at a time. For more information on

using browser mode see Browser Mode.

Caja in browser mode.
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Spatial mode: navigate your files and folders as objects

The file manager window represents a particular folder. Opening a folder opens the new window for that

folder. Each time you open a particular folder, you will find its window displayed in the same place on the

screen and the same size as the last time you viewed it (this is the reason for the name 'spatial mode').

Using spatial mode may lead to more open file manager windows on the screen. On the other hand, some

users find that representing files and folders as though they were real physical objects with particular

locations makes it easier to work with them. For more information on using spatial mode see Spatial Mode

Three Folders Opened in Spatial Mode.

Notice how, when in spatial mode, Caja indicates an open folder with a different icon.
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Spatial Mode
The following section describes how to browse your system using the Caja

file manager when configured in spatial mode. In spatial mode, each Caja window corresponds to a single

folder. When you open a folder its window appears at the same place on the screen as the last time you looked

at it. This is the default behaviour in Caja.

For a comparison of browser mode and spatial mode, see File Manager Presentation.

Spatial Windows

Spatial Window Components

Displaying Your Home Folder in a Spatial Window

Displaying a Parent Folder

Closing Folders

Displaying a Folder in a Browser Window

Opening a Location
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Spatial Windows
A new spatial window opens each time you open a folder. To open a folder, do

one of the following:

Double-click the folder's icon on the desktop or an existing window

Select the folder, and press Ctrl + O .

Select the folder, and press Alt + down arrow

Choose an item from the Places menu on the top panel. Your Home Folder and folders you have

bookmarked are listed here. For more on bookmarks, see Using Bookmarks For Your Favorite Locations.

To close the current folder while opening the new one, hold down Shift  when double-clicking, or press

Shift + Alt + down arrow .

Contents of a folder in a spatial mode. shows a spatial mode window that displays the contents of the

Computer folder.

Contents of a folder in a spatial mode.

In spatial mode each open Caja windows shows only one location. Selecting a second location will open a

second Caja window. Because each location remembers the previous position on screen in which it was

opened it allows you to easily recognize folders when many of them are open at once.

Some people consider spatial mode better, particularly for moving files or folders to different location, others

find the number of open windows daunting. Three Folders Opened in Spatial Mode. shows an example of

spatial browsing with many open locations.
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Three Folders Opened in Spatial Mode.

Because spatial mode will fill your screen with Caja windows it is important to be able to reposition

them effectively. By holding the Alt  key and clicking anywhere within the bounds of a Caja window

you may reposition it simply, instead of requiring that you reposition it by dragging its title bar.
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Spatial Window Components
The Spatial Window Components describes the components of file object

windows.

The Spatial Window Components

Component Description

Menubar Contains menus that you use to perform tasks in the file manager.

You can also open a popup menu from file manager windows. To open this popup menu right-

click in a file manager window. The items in this menu depend on where you right-click. For

example, when you right-click on a file or folder, you can choose items related to the file or

folder. When you right-click on the background of a view pane, you can choose items related

to the display of items in the view pane.

View pane
Shows the contents of the following:

Folders

FTP sites

Windows shares

WebDAV servers

Locations that correspond to special URIs

Statusbar Displays status information.

Parent

folder

selector

This drop-down list shows the hierarchy of the folder. Choose a folder from the list to open it.

Hold down Shift  while choosing from the list to close the current folder as you

open the new one.
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Displaying Your Home Folder in a
Spatial Window
To display your Home Folder, perform one of the following actions:

Double-click on the Home object on the desktop.

From a folder window's menubar, choose Places ▸ Home Folder.

From the top panel menubar, choose Places ▸ Home Folder.

The spatial window displays the contents of your Home Folder.
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Displaying a Parent Folder
A parent folder is the folder that contains the current folder. To display the

contents of your current folder's parent, do one of the following:

Choose File ▸ Open Parent.

Press Alt + up arrow .

Choose from the parent folder selector at the bottom left of the window.

To close the current folder while opening the parent, hold down Shift  while choosing from the parent

folder selector, or press Shift + Alt + up arrow .
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Closing Folders
To close folders you may simply click on the close window button, this

however may not be the most efficient way to close many windows. If you would like to view only the current

folder, and not the folders you opened to reach the current folder, choose File ▸ Close Parent Folders. If want

to close all folders on the screen, choose File ▸ Close All Folders.
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Displaying a Folder in a Browser
Window
If you wish to display a single folder in browser mode, while otherwise continuing to work in spatial mode,

perform the following steps:

1. Select a folder while in spatial mode.

2. Choose File ▸ Browse Folder.
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Opening a Location
You can open a folder or other location in spatial mode by typing its name.

Choose File ▸ Open Location ( L ), and type the path or URI of the location you wish to open.
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Browser Mode
The following section describes how to browse your system using the Caja

file manager when configured in browser mode. In browser mode, opening a folder updates the current file

manager to show the contents of the new folder.

For a comparison of browser mode and spatial mode, see File Manager Presentation.

The File Browser Window

Showing and Hiding File Browser Window Components

Using the Location Bar

Displaying Your Home Folder

Displaying a Folder

Displaying a Parent Folder

Using the Tree From the Side Pane

Using Your Navigation History
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The File Browser Window
You can access the file browser in the following ways:

Choose Applications ▸ System Tools ▸ File Browser.

While in spatial mode you may open a folder in browser mode by right clicking on that folder and

choosing Browse Folder. A new file browser window will then open and display the contents of the

selected folder.

If Caja is set to always open browser windows, double clicking any folder will open a browser window, see

Behavior Preferences.

Contents of a Folder in a File Browser Window

In some distributions of the MATE Desktop, the Home toolbar button might have another designation,

for example, Documents.

The File Browser Window Components

The File Browser Window Components
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File Browser Window Components describes the components of a file browser window.

File Browser Window Components

Component Description

Menubar Contains menus that you use to perform tasks in the file manager.

You can also open a popup menu from file manager windows. To open this popup menu right-

click in a file manager window. The items in this menu depend on where you right-click. For

example, when you right-click on a file or folder, you can choose items related to the file or

folder. When you right-click on the background of a view pane, you can choose items related

to the display of items in the view pane.

Toolbar Contains buttons that you use to perform tasks in the file manager.

Back Returns to the previously visited location. The adjacent drop down list also

contains a list of the most recently visited locations to allow you to return to them

faster.

Forward Performs the opposite function to the Back toolbar item. If you have previously

navigated back in time then this button returns you to the present.

Up Moves up one level to the parent of the current folder.

Reload Refreshes the contents of the current folder.

Home Opens your Home Folder.

Computer Opens your Computer folder.

Search Opens the search bar.

Location

bar

The location bar is a very powerful tool for navigating your computer. It can appear in three

different ways depending on your selection. For more on using the location bar see Using the

Location Bar. In all three configurations the location bar always contains the following items.

Zoom buttons: Enable you to change the size of items in the view pane.

View as drop-down list: Enables you to choose how to show items in your view pane.

Side pane
Performs the following functions:

Shows information about the current file or folder.

Enables you to navigate through your files.



To display the side pane, choose View ▸ Side Pane. The side pane contains a drop-down list

that enables you to choose what to show in the side pane. You can choose from the following

options:

Places

Displays places of particular interest.

Information

Displays the icon and information about the current folder. Buttons may appear in the

side pane, these buttons enable you to perform actions on the current folder, other than

the default action.

Tree

Displays a hierarchical representation of your file system. You can use the Tree to

navigate through your files.

History

Contains a history list of files, folders, FTP sites, and URIs that you have recently visited.

Notes

Enables you to add notes to your files and folders.

Emblems

Contains emblems that you can add to a file or folder.

To close the side pane, click on the X button at the top right of the side pane.

View pane
Shows the contents of the following:

Folders

FTP sites

Windows shares

WebDAV servers

Locations that correspond to special URIs

Statusbar Displays status information.
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Showing and Hiding File Browser
Window Components
To show or hide any of the components of the file browser described in File Browser Window Components

select any of the following items from the menu:

To hide the side pane, choose View ▸ Side Pane. To display the side pane again, choose View ▸ Side Pane

again. Alternatively you may press F9  to toggle the visibility of the side pane.

To hide the toolbar, choose View ▸ Main Toolbar. To display the toolbar again, choose View ▸ Main

Toolbar again.

To hide the location bar, choose View ▸ Location Bar. To display the location bar again, choose View ▸

Location Bar again.

To hide the statusbar, choose View ▸ Statusbar. To display the statusbar again, choose View ▸ Statusbar

again.
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Using the Location Bar
The file browser's location bar can show either a location field, a button bar,

or a search field. Each is useful in different situations.

Button bar

By default the button bar is shown. This shows a row of buttons representing the current location's

hierarchy, with a button for each containing folder. Click on the button to jump between folders in the

hierarchy. You can return to the original folder, which is shown as the last button in the row.

You can also drag buttons, for example to another location, in order to copy a folder.

The button bar.

Text Location Bar

The text location bar shows the current location as a text path, for example: '/home/user/Documents'.

The location field is particularly useful for jumping to a known folder very quickly.

To go to a new location, type a new path or edit the current one, then press Enter . The path field

automatically completes what you are typing when there is only one possibility. To accept the suggested

completion, press Tab .

To always use the text location bar, click on the toggle button at the left of the location bar.

To quickly switch to the text location bar while using the button bar, press Ctrl + L , choose Go ▸

Location, or press Leading Slash (/)  to type a path from the root directory. The location bar shows the

location buttons again after you press Enter  or cancel with Escape .

The location bar.

Search bar

By pressing Ctrl + F  or selecting the Search toolbar button the search bar appears. For more

information on searching see Searching For Files. The search bar is excellent for locating files of folders

when you are not sure of their exact location.
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The button bar.
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Displaying Your Home Folder
To quickly display your Home Folder, perform one of the following actions

from a file browser window:

Choose Go ▸ Home.

Click on the Home toolbar button.

Click on the Home button in the Places side pane.

The file browser window displays the contents of your Home Folder.
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Displaying a Folder
The contents of a folder can be displayed in either list or icon view by

selecting the appropriate item in the location bar View as menu. For more information on the list and icon

view see Using Views to Display Your Files and Folders

Double-click on the folder in the view pane.

Use the Tree in the side pane. For more information, see Using the Tree From the Side Pane.

Click on the Location buttons in the location bar.

Press Ctrl + L  to show the text Location field, type the path of the folder that you want to display,

then press Return . The Location field includes an autocomplete feature. As you type a path, the file

manager reads your file system. When you type enough characters to uniquely identify a directory, the

file manager completes the name of the directory in the Location field.

Use the Back toolbar button and the Forward toolbar button to browse through your navigation history.

To change to the folder that is one level above the current folder, choose Go ▸ Up. Alternatively, click on the

Up toolbar button.
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Displaying a Parent Folder
The parent folder of the current folder which you are browsing is the one

which exists, in a hierarchical representation, one level above the current. To display the contents of parent

folder, perform one of the following steps:

Press the Up button on the toolbar.

Choose Go ▸ Open Parent from the menubar.

Press the Backspace  key.
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Using the Tree From the Side Pane
The Tree view is one of the most useful features of the side pane. It displays a

hierarchical representation of your file system and provides a convenient way to browse and to navigate your

file system. To display the Tree in the side pane, choose Tree from the drop-down list at the top of the side

pane.

In the Treeview, open folders are represented as downwards facing arrows.

Tree Tasks describes tasks you can perform with the Tree, and how to do so.

Tree Tasks

Task Action

Open the Tree. Choose Tree from the drop-down list at the top of the side

pane.

Close the Tree. Choose another item from the drop-down list at the top of the

side pane.

Expand a folder in the Tree. Click on the arrow next to the folder in the Tree.

Collapse a folder in the Tree. Click on the arrow next to the folder in the Tree.

Display the contents of a folder in the

view pane.

Select the folder in the Tree.

Open a file. Select the file in the Tree.

You can set your preferences so that the Tree does not display files. For more information, see Views

Preferences.
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Using Your Navigation History
The file browser window maintains a history list of files, folders, FTP sites, and

URI locations you have recently visited. You can use the history list to navigate to quickly return to these

places. Your history list contains the last ten items that you viewed.

To clear your history list choose Go ▸ Clear History.

Navigating Your History List Using the Go Menu

Navigating Your History List Using the Toolbar

Navigating Your History List Using History in the Side Pane

Navigating Your History List Using the Go Menu

To display a list of previously-viewed items, choose the Go menu. Your history list is displayed in the lower part

of the Go menu. To open an item in your history list, simply click on the item.

Navigating Your History List Using the Toolbar

To use the toolbar to navigate your history list, perform one of the following actions:

To open the folder or URI in your history list, click on the Back toolbar button.

To open the folder or URI in your history list, click on the Forward toolbar button.

To display a list of previously-viewed items, click on the down arrow to the right of the Back toolbar

button. To open an item from this list, click on the item.

To display a list of items that you viewed after you viewed the current item, click on the down arrow to

the right of the Forward toolbar button. To open an item from this list, click on the item.

Navigating Your History List Using History in the Side Pane

To display the History list in the side pane, choose History from the drop-down list at the top of the side pane.

The History list in the side pane displays a list of your previously-viewed items.

To display an item from your history list in the view pane, double-click on the item in the History list.
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Opening Files
When you open a file, the file manager performs the default action for that

file type.

For example, opening a music file will play it with the default music playing application, opening a text file will

allow you to read and edit it in a text editor, and opening an image file will display the image.

The file manager checks the contents of a file to determine the type of a file. If the first lines do not

determine the type of the file, then the file manager checks the file extension.

If you open an executable text file, that is, one that Caja considers can be run as a program, then you

will be asked what you want to do: run it, or display it in a text editor. You can modify this behaviour in

the File Management preferences.

Executing the Default Action

Executing Non-Default Actions

Adding Actions

Modifying Actions
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Executing the Default Action
To execute the default action for a file, double-click on the file. For example,

the default action for plain text documents is to display the file in a text viewer. In this case, you can double-

click on the file to display the file in a text viewer.

You can set your file manager preferences so that you click once on a file to execute the default action. For

more information, see Behavior Preferences.
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Executing Non-Default Actions
To execute actions other than the default action for a file, select the file that

you want to perform an action on. In the File menu you will either have "Open with" choices, or an Open With

submenu. Select the desired option from this list.
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Adding Actions
To add actions associated with a file type, perform the following steps:

1. In the view pane, select a file of the type to which you want to add an action.

2. Choose File ▸ Open with Other Application.

3. Either choose an application in the open with dialog or browse to the program with which you wish to

open this type.

The action you have chosen is now added to the list of actions for that particular file type. If there was no prior

action associated with the type, the newly added action is the default.

You may also add actions in the Open With tabbed section under File ▸ Properties.
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Modifying Actions
To modify the actions associated with a file or file type, perform the

following steps:

1. In the view pane, select a file of the type to which you want to modify the action.

2. Choose File ▸ Properties.

3. Choose Open With tabbed section.

4. Use Add or Remove buttons to tailor the list of actions. Select the default action with the option to the

left of the list.
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Searching For Files
The Caja file manager includes an easy and simple to use way search for your

files and folders. To begin a search press Ctrl + F  or select the Search toolbar button. The search bar

should appear as in The search bar.

The search bar.

Enter characters present in the name or contents of the file or folder you wish to find and press Enter . The

results of your search should appear in the view pane as illustrated in The result of a search.

The result of a search.

If you are not happy with your search you can refine it by adding addition conditions. This allows you to restrict

the search to a specific file type or location. To add search conditions click the + icon. Restricting a search.

shows a search which has been restricted to the users home directory and to only search for text files.

Restricting a search.
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Saving Searches
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Saving Searches
Caja searches can also be saved for future use. Once saved, searches may be reopened

later. Browsing the results of a saved search. shows a user with three saved searches, browsing one of them.

Browsing the results of a saved search.

Saved searches behave exactly like regular folders, for example you can open, move or delete files from within a saved

search.
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Managing Your Files and Folders
This section describes how to work with your files and folders.

Directories and File Systems

Using Views to Display Your Files and Folders

Selecting Files and Folders

Drag-and-Drop in the File Manager

Moving a File or Folder

Copying a File or Folder

Duplicating a File or Folder

Creating a Folder

Templates and Documents

Renaming a File or Folder

Moving a File or Folder to Trash

Deleting a File or Folder

Creating a Symbolic Link to a File or Folder

Viewing the Properties of a File or Folder

File Permissions

Changing Permissions

Adding Notes to Files and Folders

Using Bookmarks For Your Favorite Locations

Using Trash

Hidden Files
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Directories and File Systems
Linux and Unix file systems are organised in a hierarchical, tree-like structure.

The highest level of the file system is the / or root directory. In the Unix and Linux design philosophy,

everything is considered a file - including hard disks, partitions and removable media. This means that all files

and directories (including other disks and partitions) exist under the root directory.

For example, /home/jebediah/cheeses.odt shows the correct full path to the cheeses.odt file that exists

in the jebediah directory which is under the home directory, which in turn, is under the root (/) directory.

Underneath the root (/) directory, there is a set of important system directories that are commonly used

across most Linux distributions. The following is a listing of common directories that are directly under the

root (/) directory:

/bin - important binary applications

/boot - files that are required to boot the computer

/dev - the device files

/etc - configuration files, startup scripts, etc...

/home - local users' home directories

/lib - system libraries

/lost+found - provides a lost+found system for files that exist under the root (/) directory

/media - mounted (loaded) removable media such as CDs, digital cameras, etc...

/mnt - mounted filesystems

/opt - provides a location for optional applications to be installed

/proc - special dynamic directory that maintains information about the state of the system, including

currently running processes

/root - root user home directory, pronounced 'slash-root'

/sbin - important system binaries

/srv - provides a location for data used by servers

/sys - contains information about the system
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/tmp - temporary files

/usr - applications and files that are mostly available for all users to access

/var - variable files such as logs and databases
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Using Views to Display Your Files
and Folders
The file manager includes views that enable you to show the contents of your folders in different ways, icon

view, and list view.

Icon view

The Home Folder displayed in a icon view. Shows the items in the folder as icons.

The Home Folder displayed in a icon view.

List view

The Home Folder displayed in a list view. Shows the items in the folder as a list.

The Home Folder displayed in a list view.
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You may use the View menu, or the View as drop-down list to choose between icon or list view. You can specify

how you want to arrange or sort items in the folder and modify the size of the items in the view pane. The

following sections describe how to work with icon view and list view.

To Arrange Your Files in Icon View

To Arrange Your Files in List View

To Change the Size of Items in a View

To Arrange Your Files in Icon View

When you display the contents of a folder in icon view, you can specify how to arrange the items in the folder.

To specify how to arrange items in icon view, choose View ▸ Arrange Items. The Arrange Items submenu

contains the following sections:

At the top is an option that enables you to arrange your files manually.

The middle section contains options that enable you to sort your files automatically.

The bottom section contains options that enable you to modify how your files are arranged.

Choose the appropriate options from the submenu, as described in the following table:

Option Description

Manually Select this option to arrange the items manually. To arrange the items manually, drag the

items to the location you require within the view pane.



By Name Select this option to sort the items alphabetically by name. The order of the items is not case

sensitive. If the file manager is set to display hidden files, the hidden files are shown last.

By Size Select this option to sort the items by size, with the largest item first. When you sort items

by size, the folders are sorted by the number of items in the folder. The folders are not sorted

by the total size of the items in the folder.

By Type Select this option to sort the items alphabetically by object type. The items are sorted

alphabetically by the description of their MIME type. The MIME type identifies the format of

a file, and enables applications to read the file. For example, an email application can use the

image/png MIME type to detect that a PNG file is attached to an email.

By

Modification

Date

Select this option to sort the items by the date the items were last modified. The most

recently modified item is first.

By Emblems Select this option to sort the items by any emblems that are added to the items. The items

are sorted alphabetically by emblem name. Items that do not have emblems are last.

Compact

Layout

Select this option to arrange the items so that the items are closer to each other.

Reversed

Order

Select this option to reverse the order of the option by which you sort the items. For

example, if you sort the items by name, select the Reversed Order option to sort the items in

reverse alphabetical order.

To Arrange Your Files in List View

When you display the contents of a folder in list view, you can specify how to arrange the items in the folder.

To specify how to arrange items in list view, click on the header of the column specifying the property by

which you wish to arrange the items. To inverse the sorting order click on the same column header again.

To add or remove columns from the list view choose View ▸ Visible Columns

The file manager remembers how you arrange the items in a particular folder. The next time that you display

the folder, the items are arranged in the way that you selected. In other words, when you specify how to

arrange the items in a folder, you customize the folder to display the items in that way. To return the

arrangement settings of the folder to the default arrangement settings specified in your preferences, choose

View ▸ Reset View to Defaults.

To Change the Size of Items in a View



You can change the size of items in a view. You can change the size if the view displays a file or a folder. You

can change the size of items in a view in the following ways:

To enlarge the size of items in a view, choose View ▸ Zoom In.

To reduce the size of items in a view, choose View ▸ Zoom Out.

To return items in a view to the normal size, choose View ▸ Normal Size.

You can also use the zoom buttons on the location bar in a browser window to change the size of items in a

view. Zoom Buttons describes how to use the zoom buttons.

Zoom Buttons

Button Button Name Description

Zoom Out button Click on this button to reduce the size of items in a view.

Normal Size button Click on this button to return items in a view to normal size.

Zoom In button Click on this button to enlarge the size of items in a view.

The file manager remembers the size of items in a particular folder. The next time that you display the folder,

the items are displayed in the size that you selected. In other words, when you change the size of items in a

folder, you customize the folder to display the items at that size. To return the size of the items to the default

size specified in your preferences, choose View ▸ Reset View to Defaults.
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Selecting Files and Folders
You can select files and folders in several ways in the file manager. Typically

this is achieved by clicking on the files using the mouse, as explained in Selecting Items in the File Manager. In

addition Selecting Files Matching a Specific Pattern describes how to select a group of files matching a

specific pattern.

Selecting Items in the File Manager

Task Action

Select an item Click on the item.

Select a group of

contiguous items

In icon view, drag around the files that you want to select.

In list view, click on the first item in the group. Press-and-hold Shift , then

click on the last item in the group.

Select multiple items Press-and-hold Ctrl . Click on the items that you want to select.

Alternatively, press-and-hold Ctrl , then drag around the files that you want to

select.

Select all items in a

folder

Choose Edit ▸ Select All Files.

To perform the default action on an item, double-click on the item. You can set your file manager preferences

so that you click once on a file to execute the default action. For more information, see Behavior Preferences.

Selecting Files Matching a Specific Pattern

Selecting Files Matching a Specific Pattern

Caja allows you to select all files matching a pattern based upon their filename and an optional number of

wildcards. This can be useful if, for example, you wish to select all files which contain the phrase "memo" in

their filename. Selecting Items in the File Manager gives some examples of possible patterns and the resulting

files they would match.

Selecting Items in the File Manager

Pattern Files Matched
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note.* This pattern would match files called note, with any extension.

*.ogg This pattern would match all files with the .ogg extension

*memo* This pattern would match all files or folders whose name contains the word memo.

To perform the Select Pattern command Choose Edit ▸ Select Patterns from the menu. After entering the

desired pattern you are left with those files or folders which matched the pattern selected. You may then do

with the selected files or folders what you choose.
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Drag-and-Drop in the File Manager
You can use drag-and-drop to perform several tasks in the file manager. When

you drag-and-drop, the mouse pointer provides feedback about the task that you perform. Drag-and-Drop in

the File Manager describes the tasks that you can perform with drag-and-drop. The table also shows the mouse

pointers that appear when you drag-and-drop.

Drag-and-Drop in the File Manager

Task Action Mouse

Pointer

Move an

item

Drag the item to the new location.

Copy an

item

Grab the item, then press-and-hold Ctrl . Drag the item to the location where you

want the copy to reside.

Create a

symbolic

link to an

item

Grab the item, then press-and-hold Ctrl + Shift . Drag the item to the location

where you want the symbolic link to reside.

Ask what

to do with

the item

you drag

Grab the item, then press-and-hold Alt . You may also use the middle mouse button

to perform the same operation. Drag the item to the location where you want the

item to reside. Release the mouse button. A popup menu appears. Choose one of the

following items from the popup menu:

Move here

Moves the item to the location.

Copy here

Copies the item to the location.

Link here

Creates a symbolic link to the item at the location.

Set as Background

If the item is an image, sets the image to be the background. You can use this
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command to set the background of the desktop, the side pane or the view pane.

Cancel

Cancels the drag-and-drop operation.
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Moving a File or Folder
You can move a file or folder by dragging it with the mouse, or with the cut

and paste commands. The following sections describe these two methods.

Drag to the New Location

Cut and Paste to the New Location

Drag to the New Location

To drag a file or folder to a new location, perform the following steps:

1. Open two file manager windows:

The window containing the item you want to move.

The window you want to move it to, or the window containing the folder you want to move it to.

2. Drag the file or folder that you want to move to the new location. If the new location is a window, drop it

anywhere in the window. If the new location is a folder icon, drop the item you are dragging on the

folder.

To move the file or folder to a folder that is one level below the current location, do not open a new window.

Instead, drag the file or folder to the new location in the same window.

For more on dragging items, see Drag-and-Drop in the File Manager.

Cut and Paste to the New Location

You can cut a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to move, then choose Edit ▸ Cut.

2. Open the folder to which you want to move the file or folder, then choose Edit ▸ Paste .
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Copying a File or Folder
You can copy a file or folder by dragging it with the mouse, or with the copy

and paste commands. The following sections describe these two methods.

Drag to the New Location

Copy and Paste to the New Location

Drag to the New Location

To copy a file or folder, perform the following steps:

1. Open two file manager windows:

The window containing the item you want to move.

The window you want to move it to, or the window containing the folder you want to move it to.

2. Drag the file or folder that you want to move to the new location. Press-and-hold Ctrl  either before or

during the drag. If the new location is a window, drop it anywhere in the window. If the new location is a

folder icon, drop the item you are dragging on the folder.

To copy the file or folder to a folder that is one level below the current location, do not open a new window.

Instead, grab the file or folder, then press-and-hold Ctrl . Drag the file or folder to the new location in the

same window.

For more on dragging items, see Drag-and-Drop in the File Manager.

Copy and Paste to the New Location

You can copy a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to copy, then choose Edit ▸ Copy.

2. Open the folder to which you want to copy the file or folder, then choose Edit ▸ Paste .
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Duplicating a File or Folder
To create a copy of a file or folder in the current folder, perform the following

steps:

1. Select the file or folder that you want to duplicate.

2. Choose Edit ▸ Duplicate.

A copy of the file or folder appears in the current folder.
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Creating a Folder
To create a folder, perform the following steps:

1. Open the folder where you want to create the new folder.

2. Choose File ▸ Create Folder. Alternatively, right-click on the background of the window, then choose

Create Folder.

An untitled folder is added to the location. The name of the folder is selected.

3. Type a name for the folder, then press Return .
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Templates and Documents
You can create templates from documents that you frequently create. For

example, if you often create invoices, you can create an empty invoice document and save the document as

invoice.doc in the $HOME/Templates folder.

You can also access the templates folder from a file browser window. Choose Go ▸ Templates.

The template name is displayed as a submenu item in the Create Document menu.

You can also create subfolders in the template folder. Subfolders display as submenus in the menu.

You can also share templates. Create a symbolic link from the template folder to the folder containing the

shared templates.

To Create a Document

To Create a Document

If you have document templates, you can choose to create a document from one of the installed templates.

To create a document perform the following steps:

1. Select the folder where you want to create the new document.

2. Choose File ▸ Create Document. Alternatively, right-click on the background of the view pane, then

choose Create Document.

The names of any available templates are displayed as submenu items from the Create Document menu.

3. Double-click on the template name for the document that you want to create.

4. Rename the document before saving to the appropriate folder.
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Renaming a File or Folder
To rename a file or folder perform the following steps:

1. Select the file or folder that you want to rename.

2. Choose Edit ▸ Rename. Alternatively, right-click on the file or folder, then choose Rename.

The name of the file or folder is selected.

3. Type a new name for the file or folder, then press Return .
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Moving a File or Folder to Trash
To move a file or folder to Trash perform the following steps:

1. Select the file or folder that you want to move to Trash.

2. Choose Edit ▸ Move to Trash. Alternatively, right-click on the file or folder, then choose Move to Trash.

Alternatively, you can drag the file or folder to the Trash object on the desktop.

When you move a file or folder from a removable media to Trash, the file or folder is stored in a Trash

location on the removable media. To remove the file or folder permanently from the removable media,

you must empty Trash.
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Deleting a File or Folder
When you delete a file or folder, the file or folder is not moved to Trash, but is

deleted from your file system immediately. The Delete menu item is only available if you select the Include a

Delete command that bypasses Trash option in the File Management Preferences dialog.

To delete a file or folder perform the following steps:

1. Select the file or folder that you want to delete.

2. Choose Edit ▸ Delete. Alternatively, right-click on the file or folder, then choose Delete.

Alternatively, select the file or folder you want to delete, and press Shift + Del .

This shortcut is independent from the Include a Delete command that bypasses Trash option.
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Creating a Symbolic Link to a File or
Folder
A symbolic link is a special type of file that points to another file or folder. When you perform an action on a

symbolic link, the action is performed on the file or folder to which the symbolic link points. However, when

you delete a symbolic link, you delete the link file, not the file to which the symbolic link points.

To create a symbolic link to a file or folder, select the file or folder to which you want to create a link. Choose

Edit ▸ Make Link. A link to the file or folder is added to the current folder.

Alternatively, grab the item to which you want to create a link, then press-and-hold Ctrl + Shift . Drag the

item to the location where you want to place the link.

By default, the file manager adds an emblem to symbolic links.

The permissions of a symbolic link are determined by the file or folder to which a symbolic link points.

For more on dragging items, see Drag-and-Drop in the File Manager.
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Viewing the Properties of a File or
Folder
To view the properties of a file or folder, perform the following steps:

1. Select the file or folder whose properties you want to view.

2. Choose File ▸ Properties. A properties dialog is displayed.

3. Use the properties dialog to view the properties of the file or folder.

4. Click Close to close the properties dialog.

The following table lists the properties that you can view or set for files and folders, the exact information

shown depends on the object type:

Property Description

Name The name of the file or folder. You can change the name here and the file or folder will be

renamed when you click on Close.

Type The type of object, file or folder for example.

Location The system path for the object. This represents where the object is situated on your computer,

relative to the system root.

Volume The volume on which a folder resides. This is the physical location of the folder, on which media

it resides, for example which hard disk or CDROM drive.

Free

space

The amount of free space on the media upon which a folder resides. This represents the

maximum amount of data you can copy to this folder.

MIME

Type

The official naming of the type of file.

Modified The date and time at which the object was last changed.

Accessed The date and time at which the object was last viewed.
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File Permissions
Permissions are settings assigned to each file and folder that determine what

type of access users can have to the file or folder. For example, you can determine whether other users can

read and edit a file that belongs to you, or only have access to read it but not make changes to it.

Each file belongs to a particular user, and is associated with a group that the owner belongs to. The super user

"root" has the ability to access any file on the system.

You can set permissions for three categories of users:

Owner

The user that created the file or folder.

Group

A group of users to which the owner belongs.

Others

All other users not already included.

For each category of user, different permissions can be set. These behave differently for files and folders, as

follows:

read

Files can be opened

Directory contents can be displayed

write

Files can be edited or deleted

Directory contents can be modified

execute

Executable files can be run as a program

Directories can be entered

For more on changing the permissions for a file or folder, see Changing Permissions.
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Changing Permissions

Changing Permissions for a File

Changing Permissions for a Folder

Changing Permissions for a File

To change the permissions of a file, perform the following steps:

1. Select the file that you want to change.

2. Choose File ▸ Properties. The Item Properties for the item is displayed.

3. Click on the Permissions tab.

4. To change the file's group, choose from the groups the user belongs to in the drop-down selector.

5. For each of the owner, the group, and all other users, choose from these permissions for the file:

None

No access to the file is possible. (You can't set this for the owner.)

Read-only

The users can open a file to see its contents, but not make any changes.

Read and write

Normal access to a file is possible: it can be opened and saved.

6. To allow a file to be run as a program, select Execute

Changing Permissions for a Folder

To change the permissions of a folder, perform the following steps:

1. Select the folder that you want to change.

2. Choose File ▸ Properties. The properties window for the item is displayed.

3. Click on the Permissions tab.

4. To change the folder's group, choose from the groups the user belongs to in the drop-down selector.

5. For each of the owner, the group, and all other users, choose from these folder access permissions:
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None

No access to the folder is possible. (You can't set this for the owner.)

List files only

The users can see the items in the folder, but not open any of them.

Access files

Items in the folder can be opened and modified, provided their own permissions allow it.

Create and delete files

The user can create new files and delete files in the folder, in addition to being able to access existing

files.

To set permissions for all the items contained in a folder, set the File Access and Execute properties and click

on Apply permissions to enclosed files.
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Adding Notes to Files and Folders
You can add notes to files or folders. You can add notes to files or folders in

the following ways:

From the properties dialog

From Notes in the side pane

To Add a Note Using the Properties Dialog

To Add a Note Using Notes in the Side Pane

To Add a Note Using the Properties Dialog

To add a note to a file or folder, perform the following steps:

1. Select the file or folder to which you want to add a note.

2. Choose File ▸ Properties. The properties window for the item is displayed.

3. Click on the Notes tab. In the Notes tabbed section, type the note.

4. Click Close to close the properties dialog. A note emblem is added to the file or folder.

To delete a note, delete the note text from the Notes tabbed section.

To Add a Note Using Notes in the Side Pane

To add a note to a file or folder, perform the following steps:

1. Open the file or folder to which you want to add a note in the view pane.

2. Choose Notes from the drop-down list at the top of the side pane. To display the side pane, choose

View ▸ Side Pane.

3. Type the note in the side pane. A note emblem is added to the file or folder in the view pane, and a note

icon is added to the side pane. You can click on this icon to display the note.

To delete a note, delete the note text from Notes in the side pane.
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Using Bookmarks For Your Favorite
Locations
You can keep a list of bookmarks in Caja: folders and other locations that you frequently need to open.

Your bookmarks are listed in the following places:

The Places menu on the top panel.

The Places menu in a folder window.

The Bookmarks menu in a Caja browser window.

The side pane in the Choosing a File to Open. This allows you to quickly open a file that is in one of your

bookmarked locations.

The list of commonly used locations in the Saving a File. This allows you to quickly save a file to a location

you have in your bookmarks.

To open an item that is in your bookmarks, choose the item from a menu.

Adding a Bookmark

To Edit a Bookmark

Adding a Bookmark

To add a bookmark, open the folder or location that you want to bookmark, then choose Places ▸ Add

Bookmark.

If you are using a Caja browser window, choose Bookmarks ▸ Add Bookmark.

To Edit a Bookmark

To edit your bookmarks perform the following steps:

1. Choose Places ▸ Edit Bookmarks, or in a browser window, Bookmarks ▸ Edit Bookmarks. An Edit

Bookmarks dialog is displayed.

2. Select the bookmark on the left side of the Edit Bookmarks dialog. Edit the details for the bookmark on

the right side of the Edit Bookmarks dialog, as follows:
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Dialog Element Description

Name Use this text box to specify the name that identifies the bookmark in the menus.

Location Use this field to specify the location of the bookmark.

Folders on your system use the file:/// URI.

3. To delete a bookmark, select the bookmark on the left side of the dialog. Click Delete.
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Using Trash

Trash is a special folder that holds files that you no longer want to keep. Files in the Trash are not deleted

permanently until you empty the trash. This two-stage process is in case you change your mind, or accidentally

remove the wrong file.

You can move the following items to Trash:

Files

Folders

Desktop objects

If you need to retrieve a file from Trash, you can display Trash and move the file out of Trash. When you empty

Trash, you delete the contents of Trash permanently.

To Display Trash

To Empty Trash

To Display Trash

You can display the contents of Trash in the following ways:

From a file browser window

Choose Go ▸ Trash. The contents of Trash are displayed in the window.

From a spatial window

Choose Places ▸ Trash. The contents of Trash are displayed in the window.

From the desktop

Double-click on the Trash object on the desktop.

To Empty Trash
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You can empty the contents of Trash in the following ways:

From a file browser window

Choose File ▸ Empty Trash.

From the desktop

Right-click on the Trash object, then choose Empty Trash.

When you empty trash, you destroy all files in the trash. Be sure that the trash only contains files you no

longer need.
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Hidden Files
By default, Caja does not display certain system and backup files in folders.

This prevents accidental modification or deletion of them, which can impair the operation of your computer,

and also reduces clutter in locations such as your Home Folder. Caja does not display:

Hidden files, whose filename begins with a period (.),

Backup files, whose filename ends with a tilde (~)

Files that are listed in a particular folder's .hidden file.

You may hide or show hidden files in a particular folder by selecting View ▸ Show Hidden Files.

To set Caja to always show hidden files, see Caja Preferences.

Hiding a File or Folder

Hiding a File or Folder

To hide a file or folder in Caja, either rename the file so its name begins with the period (.) character, or create

a text file named .hidden in the same folder, and add its name to it, as in the example below:

filename
foldername

You may need to refresh the relevant Caja window to see the change: press Ctrl + R .
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Item Properties
The Item Properties window shows more information about any file, folder, or

other item in the file manager. With this window, you can also do the following:

Change the icon for an item: see Changing the Icon for a File or Folder.

Add or remove emblems for an item: see Adding an Emblem to a File or Folder.

Change the UNIX file permissions for an item: see Changing Permissions.

Choose which application is used to open an item, and others of the same type.

Add notes to an item: see To Add a Note Using the Properties Dialog.

To open the item properties window, perform the following steps:

1. Select the item whose properties you want to examine or change. If you select more than one item, the

properties window will show the properties that are in common to all items.

2. Do one of the following:

Choose File ▸ Properties.

Right-click on the selected item and choose Properties.

Press Alt + Return .
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Modifying the Appearance of Files
and Folders
The Caja file manager enables you to modify the appearance of your files and folders in several ways. You may

customize the way files or folders look by attaching emblems or backgrounds to them. You can also change

format in which Caja displays these items to you. The following sections describe how to do so.

Icons and Emblems

Changing the Icon for a File or Folder

Adding an Emblem to a File or Folder

Creating a New Emblem

Changing Backgrounds
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Icons and Emblems
The file manager displays your files and folders as icons. Depending on the

type of the file the icon may be a image representative of the file type, a small thumbnail or preview showing

the files contents. You can also add emblems to your file and folder icons. Such emblems appear in addition to

the file icon and provide another means to manage your files. For example you can mark a file as important by

adding an Important emblem to it, creating the following visual effect:

Notice how the file on the left is distinguished from the file on the right by the addition of the Important (!)

emblem to its icon. See Adding an Emblem to a File or Folder for more on adding emblems.

The file manager automatically applies emblems for the following types of files:

Symbolic links

Items for which you have the following permissions:

No read permission

No write permission

The following table shows the default emblems:

Default Emblem Description

Symbolic link

No write permission

No read permission

Previous Next

Previous Next





Desktop User Guide » Working with Files » Modifying the Appearance of Files and Folders »

Changing the Icon for a File or
Folder
To change the icon that represents an individual file or folder, perform the following steps:

1. Select the file or folder that you want to change.

2. Choose File ▸ Properties. The Item Properties for the item is displayed.

3. On the Basic tabbed section, click on the current Icon. A Select custom icon dialog is displayed.

4. Use the Select custom icon dialog to choose the icon to represent the file or folder.

5. Click Close to close the properties dialog.

To restore an icon from a custom icon to the default icon, Select the file or folder that you want to change,

choose File ▸ Properties. click on the Icon button, in the Select custom icon dialog click Revert.
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Adding an Emblem to a File or
Folder
To add an emblem to an item perform the following steps:

1. Select the item to which you want to add an emblem.

2. Right-click on the item, then choose Properties. The properties window for the item is displayed.

3. Click on the Emblems tab to display the Emblems tabbed section.

4. Select the emblem to add to the item.

5. Click Close to close the properties dialog.

In browser windows you may also add emblems to items by dragging them from the emblem side pane.
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Creating a New Emblem
To Create a new emblem, perform the following steps:

1. Choose Edit ▸ Backgrounds and Emblems.

2. Click on the Emblem button, then click on the Add a New Emblem button. A Create a New Emblem dialog

is displayed.

3. Type a name for the emblem in the Keyword text box.

4. Click on the Image button. A dialog is displayed, click Browse. When you choose an emblem, click OK.

5. Click OK on the Create a New Emblem dialog.
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Changing Backgrounds
The file manager includes background patterns and emblems that you can use

to change the appearance of your folders. Background patterns and emblems can also be used on the desktop,

on folders and certain side panes in the file browser, and on panels.

To change the background of a window, pane, or panel, perform the following steps:

1. Choose Edit ▸ Backgrounds and Emblems in any file manager window. The Backgrounds and Emblems

dialog is displayed.

2. Click the Patterns button or the Colors button to see a list of background patterns or background colors

you can use.

3. To change the background, drag a pattern or color to the desired window, pane, or panel. To reset the

background, drag the Reset entry to the desired window, pane, or panel.

You can set the background of all folders in the file manager by dragging a pattern or color with your right or

middle mouse button. When you release the drag, you will see a popup menu with the option to set the

pattern or color as the background for all folders.

You can add a new pattern to the list by clicking the Add a New Pattern button when the patterns are

selected. Locate an image file in the file chooser dialog and click Open. The image file will appear in the list of

patterns you can use.

You can add a new color to the list by clicking the Add a New Color button when the colors are selected. Select

a color in the color chooser dialog and click OK. The color will appear in the list of colors you can use.
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Using Removable Media
The file manager can initiate various actions when removable media appear,

such as mounting it, opening a file manager window showing its contents, or running a suitable application

that can handle it (for example a music player for an audio CD). See Media Preferences for how to configure

these actions for different media formats.

To Mount Media

To Display Media Contents

To Display Media Properties

To Eject Media
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To Mount Media
To mount media is to make the file system of the media available for access.

When you mount media, the file system of the media is attached as a subdirectory to your file system.

To mount media, insert the media in the appropriate device. An icon that represents the media is added to the

desktop. The icon is added only if your system is configured to mount the device automatically when media is

detected.

If your system is not configured to mount the device automatically, you must mount the device manually.

Double-click on the Computer icon from the desktop. A Computer dialog is displayed. Double-click on the icon

that represents the media. For example, to mount a floppy diskette, double-click on the Floppy icon. An icon

that represents the media is added to the desktop.

You cannot change the name of a removable media icon.
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To Display Media Contents
You can display media contents in any of the following ways:

Double-click on the icon that represents the media on the desktop.

Right-click on the icon that represents the media on the desktop, then choose Open.

A file manager window displays the contents of the media. To reload the display, click on the Reload button.
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To Display Media Properties
To display the properties of removable media, right-click on the icon that

represents the media on the desktop, then choose Properties. A dialog displays the properties of the media.

To close the properties dialog, click Close.
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To Eject Media
To eject media, right-click on the media icon on the desktop, then choose

Eject. If the drive for the media is a motorized drive, the media is ejected from the drive. If the drive for the

media is not motorized, wait until the desktop icon for the media disappears, then eject the media manually.

You cannot eject media from a motorized drive when the media is mounted. To eject media, first unmount the

media. For example, to remove a USB flash drive, perform the following steps:

1. Close all file manager windows, Terminal windows, and any other windows that access the USB drive.

2. Right-click on the icon that represents the drive on the desktop, then choose Eject. The desktop icon for

the drive disappears.

3. Remove the USB flash drive.

You must unmount removable media before ejecting. Do not remove a USB flash drive before you

unmount the flash drive. If you do not unmount the media first you might lose data.
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Writing CDs or DVDs
Writing to a CD or DVD may be useful for backing up your important

documents. To do this, your computer must have a CD or DVD writer.

A simple way to check what sort of CD or DVD drive your computer has is to choose Places ▸ Computer

from the top panel menubar. If the icon for your CD drive has terms like "CD-RW" or "DVD(+-)R" in its

label, then your computer is able to write discs.

You can start choosing files to burn to a disc at any time. The file manager provides a special folder for files and

folders that you wish to write to a CD or DVD. From there you can easily write all of the content (which you

place in this special folder) to a CD or DVD.

Creating Data Discs

Copying CDs or DVDs

Creating a Disc from an Image File
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Creating Data Discs
To write a CD or DVD, perform the following steps:

1. Open Applications ▸ System Tools ▸ CD/DVD Creator. The file manager opens the CD/DVD Creator folder.

In a File Browser window, the CD/DVD Creator item is available in the Go menu.

2. Drag the files and folders that you want to write to CD or DVD to the CD/DVD Creator folder.

3. Insert a writable CD or DVD into the CD/DVD writer device on your system.

4. Press the Write to Disc button, or choose File ▸ Write to CD/DVD. A Write to Disc dialog is displayed.

5. Use the Write to Disc dialog to specify how you want to write the CD, as follows:

Dialog

Element

Description

Write

disc to

Select the device to which you want to write the CD from the drop-down list. To create an

CD image file, select the File image option. A CD image file is a normal file that contains all

of the data in the same format as a CD, that you can write to a CD later.

Disc

name

Type a name for the CD in the text box.

Data

size

Shows the size of the data to be written to disc. The blank disk must be at least this size.

Write

speed

Select the speed at which you want to write the CD from the drop-down list.

6. Click on the Write button.

If you selected the File image option from the Target to write to drop-down list, a Choose a filename for

the disc image dialog is displayed. Use the dialog to specify the location where you want to save the disc

image file. By default, disc image files have a .iso file extension.

A Writing disc dialog is displayed. This process takes some time. When the disc is written or when the

disc image file is created, a message to indicate that the process is complete is displayed in the dialog.
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You can set the CD/DVD Creator folder to open automatically when you instert a blank disc. See Media

Preferences.

The filesystem written to the CD will be readable with long filenames on all recent operating systems.

Both the Joliet and the Rock Ridge CD-ROM filesystem extensions are used.
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Copying CDs or DVDs
You can create a copy of a CD or DVD, either to another disc or to an image

file stored on your computer. To create a copy, perform the following steps:

1. Insert the disc you want to copy.

2. Choose Places ▸ Computer from the top panel menubar.

3. Right-click on the CD icon, and choose Copy Disc.

4. The Write to Disc dialog is displayed.

If you have only one drive with write capabilities, the process will first create a disc image file on your

computer. It will then eject the original disk, and ask you to change it for a blank disk on which to write the

copy.

If you want to create more than one copy, choose the Image File option on the Write to Disc and then

write the disc image: see Creating a Disc from an Image File.
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Creating a Disc from an Image File
You can write a disc image to a CD or DVD. For example, you may have

downloaded a disc image from the internet, or previously created one yourself. Disc images usually have a

.iso file extension and are sometimes called iso files.

To write a disc image, right-click on the disc image file, then choose Write to Disc from the popup menu.
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Navigating Remote Servers
The Caja file manager provides an integrated access point to your files,

applications, FTP sites, Windows shares, WebDav servers and SSH servers.

To Access a remote server

To Access Network Places

Accessing Special URI Locations
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To Access a remote server
You can use the file manager to access a remote server, be it an FTP site, a

Windows share, a WebDav server or an SSH server.

To access a remote server, choose File ▸ Connect to Server. You may also access this dialog from the menubar

by choosing Places ▸ Connect to Server.

To connect to a remote server, start by choosing the service type, then enter the server address.

If required by your server, you may provide the following optional information :

Dialog

Element

Description

Port Port to connect to on the server. This should only be used if it is necessary to change the

default port, you would normally leave this blank.

Folder Folder to open upon connecting to server.

User Name The user name of the account used to connect to the server. This should be supplied with the

connection information if needed. The user name information is not appropriate for a public

FTP connection.

Name to

use for

connection

The designation of the connection as it will appear in the file manager.

Share Name of desired windows share. This is only applicable to Windows shares.

Domain

name

Windows domain. This is only applicable to Windows shares.

If the server information is provided in the form of a URI, or you require a specialized connection, choose

Custom Location as the service type.

Once you have filled in the information, click on the Connect button. When the connection succeeds, the

contents of the site are displayed and you may drag and drop files to and from the remote server.
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To Access Network Places
If your system is configured to access places on a network, you can use the

file manager to access the network places.

To access network places, open the file manager and choose Places ▸ Network Servers. A window opens that

displays the network places that you can access. Double-click on the network that you want to access.

To access UNIX shares, double-click on the Unix Network (NFS) object. A list of the UNIX shares available to

you is displayed in the file manager window.

To access Windows shares, double-click on the Windows Network (SMB) object. A list of the Windows shares

available to you is displayed in the file manager window.
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Accessing Special URI Locations
Caja has certain special URI locations that enable you to access particular

functions from the file manager.

These are intended for advanced users: in most cases, an easier method of accessing the function or location

exists.

Special URI Locations lists the special URI locations that you can use with the file manager.

Special URI Locations

URI Location Description

burn:/// This is a special location where you can copy files and folders that you want to write to a

CD. From here you can write the contents of the location to a CD easily. See also Writing

CDs or DVDs.

network:/// Displays network locations to which you can connect, if your system is configured to access

locations on a network. To access a network location, double-click on the network location.

You can also use this URI to add network locations to your system. See also To Access

Network Places.
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Caja Preferences
Use the File Management Preferences dialog to customize the file manager

to suit your requirements and preferences.

To display the File Management Preferences dialog, choose Edit ▸ Preferences. You can also access this dialog

directly from the top panel Menubar by choosing System ▸ Preferences ▸ File Management.

You can set preferences in the following categories:

The default settings for views.

The behavior of files and folders, executable text files, and Trash.

The information that is displayed in icon captions and the date format.

The columns that appear in the list view and their order.

Preview options to improve the performance of the file manager.

How removable media and connected devices are handled.

Views Preferences

Behavior Preferences

Display Preferences

List Columns Preferences

Preview Preferences

Media Preferences
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Views Preferences
You can specify a default view, and select sort options and display options.

You can also specify default settings for icon views and list views.

To specify your default view settings, choose Edit ▸ Preferences. Click on the Views tab to display the Views

tabbed section.

Views Preferences lists the views preferences that you can modify.

Views Preferences

Dialog Element Description

View new folders

using

Select the default view for folders. When you open a folder, the folder is displayed

in the view that you select. This can be the icon view, the list view, or the compact

view, which is a variant of the icon view that is organized in columns rather than

rows..

Arrange items Select the characteristic by which you want to sort the items in folders that are

displayed in this view.

Sort folders before

files

Select this option to list folders before files when you sort a folder.

Show hidden and

backup files

Select this option to display files that are normally not shown in folders. For more

on hidden files, see Hidden Files.

Default zoom level in

the Icon View,

Compact View, or List

View sections

Select the default zoom level for folders that are displayed in this view. The zoom

level specifies the size of items in a view.

Use compact layout Select this option to arrange the items in icon view so that the items in the folder

are closer to each other.

Text beside icons Select this option to place the icon captions for items beside the icon rather than

under the icon.

All columns have the

same width

Select this option to make all columns in a compact view have the same width.

Show only folders Select this option to display only folders in the Tree in the side pane.
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Behavior Preferences
To set your preferences for files and folders, choose Edit ▸ Preferences. Click

on the Behavior tab to display the Behavior tabbed section. You can set the following preferences:

Single click to open items

Select this option to perform the default action for an item when you click on the item. When this option is

selected, and you point to an item, the title of the item is underlined.

Double click to open items

Select this option to perform the default action for an item when you double-click on the item.

Always open in browser windows

Select this option to use Caja in browser mode rather than spatial mode. Selecting this lets you browse

your files and folders in the same window, otherwise you will navigate your files and folders as objects.

Run executable text files when they are opened

Select this option to run an text executable file when you choose the file. An executable text file is a text

file that can execute, that is, a shell script.

View executable text files when they are opened

Select this option to display the contents of an executable text file when you choose the executable text

file.

Ask each time

Select this option to display a dialog when you choose an executable text file. The dialog asks whether you

want to execute the file or display the file.

Ask before emptying the Trash or deleting files

Select this option to display a confirmation message before Trash is emptied, or files are deleted. Leave

this selected unless you have good reason not to.

Include a Delete command that bypasses Trash

Select this option to add a Delete menu item to the following menus:

The Edit menu.

The popup menu that is displayed when you right-click on a file, folder, or desktop object.

When you select an item then choose the Delete menu item, the item is deleted from your file system

immediately. There is no way to recover a deleted file. Do not select this unless you have good reason to.
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Display Preferences
An icon caption displays the name of a file or folder in an icon view. The icon

caption also includes three additional items of information on the file or folder. The additional information is

displayed after the file name. Normally only one item of information is visible, but when you zoom in on an

icon, more of the information is displayed. You can modify what additional information is displayed in icon

captions.

To set your preferences for icon captions, choose Edit ▸ Preferences. Click on the Display tab to display the

Display tabbed section.

Select the items of information that you want to display in the icon caption from the three drop-down lists.

Select the first item from the first drop-down list, select the second item from the second drop-down list, and

so on. The following table describes the items of information that you can select:

Information Description

Size Choose this option to display the size of the item.

Type Choose this option to display the description of the MIME type of the item.

Date

Modified

Choose this option to display the last modification date of the item.

Date

Accessed

Choose this option to display the date that the item was last accessed.

Owner Choose this option to display the owner of the item.

Group Choose this option to display the group to which the item belongs.

Permissions Choose this option to display the permissions of the item as three sets of three characters,

for example -rwxrw-r--.

Octal

Permissions

Choose this option to display the permissions of the item in octal notation, for example 764.

MIME Type Choose this option to display the MIME type of the item.

None Choose this option to display no information for the item.

The date Format option lets you choose how the date is displayed throughout Caja.
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List Columns Preferences
You can specify what information is displayed in list view in file manager

windows. You can specify which columns are displayed in list view, and the order in which the columns are

displayed.

To set your preferences for list columns, choose Edit ▸ Preferences. Click on the List Columns tab to display

the List Columns tabbed section.

To specify a column to display in list view, select the option that corresponds to the column, then click on the

Show button. To remove a column from the list view, select the option that corresponds to the column, then

click on the Hide button.

Use the Move Up and Move Down buttons to specify the position of columns in list view.

To use the default columns and column positions, click on the Use Default button.

The following table describes the columns that you can display:

Information Description

Name Choose this option to display the name of the item.

Size Choose this option to display the size of the item.

Type Choose this option to display the description of the MIME type of the item from the File

Types and Programs preference tool.

Date

Modified

Choose this option to display the last modification date of the item.

Date

Accessed

Choose this option to display the date that the item was last accessed.

Group Choose this option to display the group to which the item belongs.

MIME type Choose this option to display the MIME type of the item.

Octal

Permissions

Choose this option to display the permissions of the item in octal notation, for example 764.

Owner Choose this option to display the owner of the item.
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Permissions Choose this option to display the permissions of the item as three sets of three characters,

for example -rwxrw-r--.
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Preview Preferences
The file manager include some file preview features. The preview features

can affect the speed with which the file manager responds to your requests. You can modify the behavior of

some of these features to improve the speed of the file manager. For each preview preference, you can select

one of the options described in the following table:

Option Description

Always Performs the action for both local files, and files on other file systems.

Local Files Only Performs the action for local files only.

Never Never performs the action.

To set your preview preferences, choose Edit ▸ Preferences. Click on the Preview tab dialog to display the

Preview tabbed section.

Preview Preferences lists the preview preferences that you can modify.

Preview Preferences

Dialog

Element

Description

Show text

in icons

Select an option to specify when to preview the content of text files in the icon that

represents the file.

Show

thumbnails

Select an option to specify when to show thumbnails of image files. The file manager stores

the thumbnail files for each folder in a .thumbnails directory in the user's Home Folder.

Only for

files smaller

than

Specify the maximum file size for files for which the file manager creates a thumbnail.

Preview

sound files

Select an option to specify when to preview sound files.

Count

number of

items

Select an option to specify when to show the number of items in folders. When in icon view,

you might need to increase your zoom level to see the number of items in each folder.
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Media Preferences
You can configure how Caja handles removable media and devices that are

connected to the computer, such as music players or cameras. For each media format or device type, Caja

offers to run one of the applications that are known to support this format, as well as the following options:

Option Description

Ask what to

do

Make Caja ask for the desired action when the media or device appears.

Do Nothing Do nothing.

Open Folder Treat the media or device like an ordinary folder and open it in a Caja window.

Open with

other

Application

Select an application to run with the Caja application chooser dialog. Note that applications

known to handle the media or device can be chosen directly from the drop-down list.

The most common media formats can be configured in the Media Handling section: audio CDs, video DVDs,

music players, cameras, and software cds.

To configure the handling for other media formats, first select the format in the Type drop-down list, then

select the desired handling for this format in the Action drop-down list.

Preview Preferences lists other media handling preferences that you can modify.

Preview Preferences

Dialog Element Description

Never prompt or

start programs on

media insertion

Select this option to prevent Caja from showing dialogs or running programs when

media or devices appear. When this option is selected, the preferences for the

handling of specific media formats are ignored.

Browse media

when inserted

When this option is selected, Caja will automatically open a folder when media is

inserted. This only applies for media formats for which the handling has not been

explicitly configured.
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Extending Caja
Caja can be extended in two main ways. Through Caja extensions, and

through scripts. This section explains the difference between the two and how to install.

Caja Scripts

Caja Extensions
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Caja Scripts
Caja can run scripts. Scripts are typically simpler in operation than full Caja

extensions and can be written in any scripted language capable of being executed on your computer. To run a

script choose File ▸ Scripts, then choose the script that you want to run from the submenu.

To run a script on a particular file, select the file in the view pane. Choose File ▸ Scripts, then choose the script

that you want to run on the file from the submenu. You can also select multiple files to run your scripts on.

You may also access scripts from the context menu.

If you do not have any scripts installed, the script menu will not appear.

Installing File Manager Scripts

Writing File Manager Scripts

Installing File Manager Scripts

The file manager includes a special folder where you can store your scripts. All executable files in this folder

will appear in the Scripts menu. The script folder is located at $HOME/.config/caja/scripts.

To install a script, simply copy the script to the script folder and give it the user executable permission.

To view the contents of your scripts folder, if you already have scripts installed, choose File ▸ Scripts ▸ Open

Scripts Folder. You will have to navigate to the scripts folder with the file manager if you do not yet have any

scripts. You may need to show hidden files for this, use View ▸ Show Hidden Files

A good source to download Caja scripts is from the G-Scripts website.

Writing File Manager Scripts

When executed from a local folder, scripts will be passed the selected file names. When executed from a

remote folder (e.g. a folder showing web or ftp content), scripts will be passed no parameters.

The following table shows variables passed to the script :

Environment variable Description

CAJA_SCRIPT_SELECTED_FILE_PATHS newline-delimited paths for selected files (only if local)

CAJA_SCRIPT_SELECTED_URIS newline-delimited URIs for selected files
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CAJA_SCRIPT_CURRENT_URI URI for current location

CAJA_SCRIPT_WINDOW_GEOMETRY position and size of current window
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Caja Extensions
Caja extensions are far more powerful than Caja scripts, allowing more

freedom where and how they extend Caja. Caja extensions are typically installed by your system administrator.

Some popular Caja extensions include:

1. caja-actions

This extension allows you to easily assign actions based on file type

2. caja-send-to

This extension provides a simple way to send a file or folder to another using email, instant messaging, or

Bluetooth.

3. caja-open-terminal.

This extension provides an easy way to open a terminal at the selected starting location.

If you are looking for the Open Terminal command which used to exist in the Caja right click menu by

default then you should install the caja-open-terminal extension.
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